En bref
- CVE-2026-8212 est une vulnérabilité MOYENNE (CVSS 5.5) touchant gdal, gdal (osgeo).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.21%, plus élevée que 10.5% des vulnérabilités.
- Correctif : mettre à jour vers 3.13.0RC1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| gdal PyPI | < 3.13.0RC1
| 3.13.0RC1
|
| gdal | = 3.13.0≤ 3.12.4
| No fix yet |
Description
A flaw has been found in OSGeo gdal up to 3.13.0dev-4. Affected by this vulnerability is the function SWSDfldsrch of the file frmts/hdf4/hdf-eos/SWapi.c. Executing a manipulation can lead to heap-based buffer overflow. The attack requires local access. The exploit has been published and may be used. Upgrading to version 3.13.0RC1 addresses this issue. This patch commit sha is 3e04c0385630e4d42517046d9a4967dfccfeb7fd. The affected component should be upgraded.
NVD description
A flaw has been found in OSGeo gdal up to 3.13.0dev-4. Affected by this vulnerability is the function SWSDfldsrch of the file frmts/hdf4/hdf-eos/SWapi.c. Executing a manipulation can lead to heap-based buffer overflow. The attack requires local access. The exploit has been published and may be used. Upgrading to version 3.13.0RC1 addresses this issue. This patch is called 3e04c0385630e4d42517046d9a4967dfccfeb7fd. The affected component should be upgraded.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free