En bref
- CVE-2026-82259 est une vulnérabilité ÉLEVÉE (CVSS 7.5) touchant sveltekit (svelte), @sveltejs/kit.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.53%, plus élevée que 45.0% des vulnérabilités.
- Correctif : mettre à jour vers 2.53.3 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| sveltekit | ≥ 2.49.0, < 2.53.3
| 2.53.3
|
| @sveltejs/kit npm | ≥ 2.49.0, < 2.53.3
| 2.53.3
|
Description
Some relatively small inputs can cause very large files arrays in form handlers. If the SvelteKit application code doesn't check files.length or individual files' sizes and performs expensive processing with them, it can result in Denial of Service.
Only users with experimental.remoteFunctions: true who are using the form function and are processing the files array without validation are vulnerable.
NVD description
SvelteKit versions from 2.49.0 through 2.53.2 (fixed in 2.53.3) contain a deserialization expansion issue in the experimental form remote function. When an application enables experimental.remoteFunctions and uses the form function to process the files array without validating files.length or individual file sizes, an attacker can submit relatively small inputs that expand into very large file arrays, leading to expensive processing and denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free