En bref
- CVE-2026-82858 est une vulnérabilité CRITIQUE (CVSS 9.8) touchant @hulumi/drift.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.29%, plus élevée que 21.0% des vulnérabilités.
- Correctif : mettre à jour vers 1.3.2 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| @hulumi/drift npm | < 1.3.2
| 1.3.2
|
Description
Impact: @hulumi/drift versions before 1.3.2 could accept externally supplied execute plans without sufficient provenance checks, allowing unsafe reconciliation input to be treated as trusted.
Patched in 1.3.2: execute-plan handling now validates provenance and rejects untrusted plans, with regression coverage.
Remediation: upgrade @hulumi/drift to 1.3.2 or later.
NVD description
@hulumi/drift versions before 1.3.2 accept externally supplied execute plans without sufficient provenance validation, allowing untrusted reconciliation input to be treated as trusted. Attackers can supply malicious execute plans that bypass security checks to perform unsafe reconciliation operations.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free