En bref
- CVE-2026-84310 est une vulnérabilité FAIBLE (CVSS 3.3) touchant pypdf, pypdf (py-pdf).
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.14%, plus élevée que 2.9% des vulnérabilités.
- Correctif : mettre à jour vers 6.16.1 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.16.1
| 6.16.1
|
| pypdf | < 6.16.1
| 6.16.1
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to long runtimes and large memory consumption. This requires accessing the outlines of a document with either lots of entries or nested outlines with long re-used nesting paths.
Patches
This has been fixed in pypdf==6.16.1.
Workarounds
If you cannot upgrade yet, consider applying the changes from PR #3966.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.16.1, an attacker can craft a PDF that causes pypdf/_doc_common.py _get_outline to consume long runtimes and large amounts of memory when retrieving document outlines with large numbers of entries or deeply nested reused paths because the traversal lacked global entry-count and nesting-depth limits. This issue is fixed in version 6.16.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free