En bref
- CVE-2026-94484 est une vulnérabilité MOYENNE (CVSS 4.8) touchant next.js (vercel), next.
- Probabilité d'exploitation dans les 30 prochains jours (EPSS) : 0.24%, plus élevée que 15.7% des vulnérabilités.
- Correctif : mettre à jour vers 15.5.27, 16.3.8 ou plus récent.
| Package | Affected versions | Patched versions |
|---|
| next.js | ≥ 15.0.0, < 15.5.27≥ 16.0.0, < 16.3.8
| 15.5.2716.3.8
|
| next npm | ≥ 15.0.0, < 15.5.27≥ 16.0.0, < 16.3.8
| 15.5.2716.3.8
|
Description
Next.js applications that use a root-level catch-all page together with statically generated or Incremental Static Regeneration routes can have their shared response cache poisoned by a single unauthenticated crafted request.
NVD description
Next.js is a React framework for building full-stack web applications. From 15.0.0 until 15.5.27 and 16.3.8, applications with a root-level catch-all page and statically generated or Incremental Static Regeneration routes can use a shared response cache key that is insufficiently scoped to the source route. A single unauthenticated crafted request can poison that cache, causing cross-user content substitution or persistent denial of service until the poisoned entry is revalidated or replaced. This issue is fixed in versions 15.5.27 and 16.3.8.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free