| Package | Affected versions | Patched versions |
|---|---|---|
| nokogiri | < 1.13.4 | 1.13.4 |
Nokogiri v1.13.4 updates the vendored org.cyberneko.html library to 1.9.22.noko2 which addresses CVE-2022-24839. That CVE is rated 7.5 (High Severity).
See GHSA-9849-p7jc-9rmv for more information.
Please note that this advisory only applies to the JRuby implementation of Nokogiri < 1.13.4.
Upgrade to Nokogiri >= 1.13.4.
org.cyberneko.html used by Nokogiri (Rubygem) raises a java.lang.OutOfMemoryError exception when parsing ill-formed HTML markup.Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free