| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.tomcat:tomcat | ≥ 5.5.0, < 5.5.33≥ 6.0.0, < 6.0.32≥ 7.0.0, < 7.0.7 | 5.5.336.0.327.0.7 |
| jdk | = 1.5.0= 1.6.0≤ 1.5.0≤ 1.6.0 | |
| jre | = 1.4.2= 1.4.2_1= 1.4.2_10= 1.4.2_11= 1.4.2_12= 1.4.2_13= 1.4.2_14= 1.4.2_15= 1.4.2_16= 1.4.2_17= 1.4.2_18= 1.4.2_19= 1.4.2_2= 1.4.2_20= 1.4.2_21= 1.4.2_22= 1.4.2_23= 1.4.2_24= 1.4.2_25= 1.4.2_26= 1.4.2_27= 1.4.2_28= 1.4.2_3= 1.4.2_4= 1.4.2_5= 1.4.2_6= 1.4.2_7= 1.4.2_8= 1.4.2_9= 1.5.0= 1.6.0≤ 1.4.2_29≤ 1.5.0≤ 1.6.0 | |
| sdk | = 1.4.2= 1.4.2_02= 1.4.2_1= 1.4.2_10= 1.4.2_11= 1.4.2_12= 1.4.2_13= 1.4.2_14= 1.4.2_15= 1.4.2_16= 1.4.2_17= 1.4.2_18= 1.4.2_19= 1.4.2_20= 1.4.2_21= 1.4.2_22= 1.4.2_23= 1.4.2_24= 1.4.2_25= 1.4.2_26= 1.4.2_27= 1.4.2_28= 1.4.2_3= 1.4.2_4= 1.4.2_5= 1.4.2_6= 1.4.2_7= 1.4.2_8= 1.4.2_9≤ 1.4.2_29 |
The Double.parseDouble method in Java Runtime Environment (JRE) in Oracle Java SE and Java for Business 6 Update 23 and earlier, 5.0 Update 27 and earlier, and 1.4.2_29 and earlier, as used in OpenJDK, Apache, JBossweb, and other products, allows remote attackers to cause a denial of service via a crafted string that triggers an infinite loop of estimations during conversion to a double-precision binary floating-point number, as demonstrated using 2.2250738585072012e-308.
Apache Tomcat introduced workarounds to avoid being affected by this issue in versions 7.0.7, 6.0.32, and 5.5.33.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free