In breve
- CVE-2014-3743 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda marked (marked project), marked.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.7%, superiore al 77.5% delle vulnerabilità.
- Correzione: aggiornare a 0.3.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| marked | < 0.3.1
| 0.3.1
|
| marked npm | < 0.3.1
| 0.3.1
|
Description
Versions 0.3.0 and earlier of marked are affected by two cross-site scripting vulnerabilities, even when sanitize: true is set.
The attack vectors for this vulnerability are GFM Codeblocks and JavaScript URLs.
Recommendation
Upgrade to version 0.3.1 or later.
NVD description
Multiple cross-site scripting (XSS) vulnerabilities in the Marked module before 0.3.1 for Node.js allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) gfm codeblocks (language) or (2) javascript url's.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free