| Package | Affected versions | Patched versions |
|---|---|---|
| serve-static | ≤ 1.7.1 | |
| serve-static | ≥ 1.7.0, < 1.7.2< 1.7.2 | 1.7.2 |
Versions of serve-static prior to 1.6.5 ( or 1.7.x prior to 1.7.2 ) are affected by an open redirect vulnerability on some browsers when configured to mount at the root directory.
A link to http://example.com//www.google.com/%2e%2e will redirect to //www.google.com/%2e%2e
Some browsers will interpret this as http://www.google.com/%2e%2e, resulting in an external redirect.
Version 1.7.x: Update to version 1.7.2 or later. Version 1.6.x: Update to version 1.6.5 or later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free