In breve
- CVE-2015-5688 è una vulnerabilità MEDIO (CVSS 5.0) che riguarda geddy (geddyjs), geddy.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 9.4%, superiore al 95.4% delle vulnerabilità.
- Correzione: aggiornare a 13.0.8 o successiva.
| Package | Affected versions | Patched versions |
|---|
| geddy | = 13.0.7
| No fix yet |
| geddy npm | < 13.0.8
| 13.0.8
|
Description
Versions 13.0.8 and earlier of geddy are vulnerable to a directory traversal attack via URI encoded attack vectors.
Proof of Concept
http://localhost:4000/..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2f..%2fetc/passwd
Recommendation
Update geddy to version >= 13.0.8
NVD description
Directory traversal vulnerability in lib/app/index.js in Geddy before 13.0.8 for Node.js allows remote attackers to read arbitrary files via a ..%2f (dot dot encoded slash) in the PATH_INFO to the default URI.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free