In breve
- CVE-2016-10554 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda sequelize (sequelizejs), sequelize.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.9%, superiore al 79.5% delle vulnerabilità.
- Correzione: aggiornare a 1.7.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| sequelize | = 1.7.0≤ 1.6.0
| No fix yet |
| sequelize npm | < 1.7.0
| 1.7.0
|
Description
Affected versions of sequelize use MySQL's backslash-based escape syntax when connecting to SQLite, despite the fact that SQLite uses PostgreSQL's escape syntax, which can result in a SQL Injection vulnerability.
Recommendation
Update to version 1.7.0-alpha3 or later.
NVD description
sequelize is an Object-relational mapping, or a middleman to convert things from Postgres, MySQL, MariaDB, SQLite and Microsoft SQL Server into usable data for NodeJS. Before version 1.7.0-alpha3, sequelize defaulted SQLite to use MySQL backslash escaping, even though SQLite uses Postgres escaping.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free