In breve
- CVE-2016-10558 è una vulnerabilità ALTO (CVSS 8.1) che riguarda aerospike (aerospike), aerospike.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.7%, superiore al 77.5% delle vulnerabilità.
- Correzione: aggiornare a 2.4.2 o successiva.
Description
Affected versions of aerospike insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running aerospike.
Recommendation
Update to version 2.4.2 or later
NVD description
aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free