In breve
- CVE-2016-10574 è una vulnerabilità ALTO (CVSS 8.1) che riguarda apk-parser3 (apk-parser3 project), apk-parser3.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.7%, superiore al 77.7% delle vulnerabilità.
- Correzione: aggiornare a 0.1.3 o successiva.
Description
Affected versions of apk-parser3 insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running apk-parser3.
Recommendation
Update to version 0.1.3 or greater.
NVD description
apk-parser3 is a module to extract Android Manifest info from an APK file. apk-parser3 versions before 0.1.3 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free