In breve
- CVE-2016-10582 è una vulnerabilità ALTO (CVSS 8.1) che riguarda closurecompiler (closurecompiler project), closurecompiler.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.7%, superiore al 76.7% delle vulnerabilità.
- Nessuna versione corretta ancora nota: segui l'avviso del produttore nei riferimenti.
Description
Affected versions of closurecompiler insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running closurecompiler.
Recommendation
Update to version 1.6.1 or later.
NVD description
closurecompiler is a Closure Compiler for node.js. closurecompiler downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free