In breve
- CVE-2017-1001002 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda math.js (mathjs), mathjs.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 2.4%, superiore al 83.8% delle vulnerabilità.
- Correzione: aggiornare a 3.17.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| math.js | ≤ 3.17.0
| No fix yet |
| mathjs npm | < 3.17.0
| 3.17.0
|
Description
math.js before 3.17.0 had an arbitrary code execution in the JavaScript engine. Creating a typed function with JavaScript code in the name could result arbitrary execution.
Recommendation
Update to version 3.17.0 or later.
NVD description
math.js before 3.17.0 had an arbitrary code execution in the JavaScript engine. Creating a typed function with JavaScript code in the name could result arbitrary execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free