In breve
- CVE-2017-16007 è una vulnerabilità MEDIO (CVSS 5.9) che riguarda node-jose (cisco), node-jose.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.91%, superiore al 60.1% delle vulnerabilità.
- Correzione: aggiornare a 0.9.3 o successiva.
Description
Affected versions of node-jose are vulnerable to an invalid curve attack. This allows an attacker to recover the private secret key when JWE with Key Agreement with Elliptic Curve Diffie-Hellman Ephemeral Static (ECDH-ES) is used.
Proof of Concept
Recommendation
Update to version 0.9.3 or later.
NVD description
node-jose is a JavaScript implementation of the JSON Object Signing and Encryption (JOSE) for current web browsers and node.js-based servers. node-jose earlier than version 0.9.3 is vulnerable to an invalid curve attack. This allows an attacker to recover the private secret key when JWE with Key Agreement with Elliptic Curve Diffie-Hellman Ephemeral Static (ECDH-ES) is used.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free