In breve
- CVE-2017-16043 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda shout (shout project), shout.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.00%, superiore al 63.0% delle vulnerabilità.
- Correzione: aggiornare a 0.50.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| shout | ≥ 0.44.0, < 0.50.0
| 0.50.0
|
| shout npm | ≥ 0.44.0, < 0.50.0
| 0.50.0
|
Description
Affected versions of shout do not escape the /topic command in messages, and are therefore vulnerable to cross-site scripting.
Recommendation
Update to version 0.50.0 or later.
NVD description
Shout is an IRC client. Because the `/topic` command in messages is unescaped, attackers have the ability to inject HTML scripts that will run in the victim's browser. Affects shout >=0.44.0 <=0.49.3.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free