In breve
- CVE-2017-16099 è una vulnerabilità ALTO (CVSS 7.5) che riguarda no-case (no-case project), no-case.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.6%, superiore al 75.4% delle vulnerabilità.
- Correzione: aggiornare a 2.3.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| no-case | < 2.3.2
| 2.3.2
|
| no-case npm | < 2.3.2
| 2.3.2
|
Description
Affected versions of no-case are vulnerable to a regular expression denial of service when parsing untrusted user input.
Recommendation
Update to version 2.3.2 or later.
NVD description
The no-case module is vulnerable to regular expression denial of service. When malicious untrusted user input is passed into no-case it can block the event loop causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free