In breve
- CVE-2017-16119 è una vulnerabilità ALTO (CVSS 7.5) che riguarda fresh (fresh project), fresh.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.6%, superiore al 75.6% delle vulnerabilità.
- Correzione: aggiornare a 0.5.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| fresh | < 0.5.2
| 0.5.2
|
| fresh npm | < 0.5.2
| 0.5.2
|
Description
Affected versions of fresh are vulnerable to regular expression denial of service when parsing specially crafted user input.
Recommendation
Update to version 0.5.2 or later.
NVD description
Fresh is a module used by the Express.js framework for HTTP response freshness testing. It is vulnerable to a regular expression denial of service when it is passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free