In breve
- CVE-2017-18214 è una vulnerabilità ALTO (CVSS 7.5) che riguarda moment (momentjs), nessus (tenable), moment.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 3.6%, superiore al 89.6% delle vulnerabilità.
- Correzione: aggiornare a 2.19.3 o successiva.
| Package | Affected versions | Patched versions |
|---|
| moment | ≤ 2.19.2
| No fix yet |
| nessus | ≤ 8.2.3
| No fix yet |
| moment npm | < 2.19.3
| 2.19.3
|
Description
Affected versions of moment are vulnerable to a low severity regular expression denial of service when parsing dates as strings.
Recommendation
Update to version 2.19.3 or later.
NVD description
The moment module before 2.19.3 for Node.js is prone to a regular expression denial of service via a crafted date string, a different vulnerability than CVE-2016-4055.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free