In breve
- CVE-2017-7235 è una vulnerabilità ALTO (CVSS 8.8) che riguarda cfscrape, cloudflare-scrape (cloudflare-scrape project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.5%, superiore al 75.2% delle vulnerabilità.
- Correzione: aggiornare a 1.8.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| cfscrape PyPI | ≥ 1.6.6, < 1.8.0
| 1.8.0
|
| cloudflare-scrape | = 1.6.6= 1.6.7= 1.6.8= 1.7.0= 1.7.1
| No fix yet |
Description
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
NVD description
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free