In breve
- CVE-2018-1000088 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda doorkeeper, doorkeeper (doorkeeper project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.4%, superiore al 73.1% delle vulnerabilità.
- Correzione: aggiornare a 4.2.6 o successiva.
| Package | Affected versions | Patched versions |
|---|
| doorkeeper RubyGems | ≥ 2.1.0, < 4.2.6
| 4.2.6
|
| doorkeeper | ≥ 2.1.0, ≤ 4.2.5
| No fix yet |
Description
Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.
NVD description
Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link.. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free