In breve
- CVE-2018-1000620 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda cryptiles (cryptiles project), cryptiles.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.7%, superiore al 77.1% delle vulnerabilità.
- Correzione: aggiornare a 4.1.2, 3.1.3 o successiva.
| Package | Affected versions | Patched versions |
|---|
| cryptiles | ≥ 4.1.0, < 4.1.2< 3.1.3
| 4.1.23.1.3
|
| cryptiles npm | ≥ 3.1.0, < 3.1.3≥ 4.0.0, < 4.1.2
| 3.1.34.1.2
|
Description
Versions of cryptiles prior to 4.1.2 are vulnerable to Insufficient Entropy. The randomDigits() method does not provide sufficient entropy and its generates digits that are not evenly distributed.
Recommendation
Upgrade to version 4.1.2. The package is deprecated and has been moved to @hapi/cryptiles and it is strongly recommended to use the maintained package.
NVD description
Eran Hammer cryptiles version 4.1.1 earlier contains a CWE-331: Insufficient Entropy vulnerability in randomDigits() method that can result in An attacker is more likely to be able to brute force something that was supposed to be random.. This attack appear to be exploitable via Depends upon the calling application.. This vulnerability appears to have been fixed in 4.1.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free