In breve
- CVE-2018-16476 è una vulnerabilità ALTO (CVSS 7.5) che riguarda activejob, cloudforms (redhat), rails (rubyonrails).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 2.9%, superiore al 86.8% delle vulnerabilità.
- Correzione: aggiornare a 4.2.11, 5.0.7.1, 5.1.6.1, 5.2.1.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| activejob RubyGems | ≥ 4.2.0, < 4.2.11≥ 5.0.0, < 5.0.7.1≥ 5.1.0, < 5.1.6.1≥ 5.2.0, < 5.2.1.1
| 4.2.115.0.7.15.1.6.15.2.1.1
|
| cloudforms | = 4.6
| No fix yet |
| rails | ≥ 4.2.0, < 4.2.11≥ 5.0.0, < 5.0.7.1≥ 5.1.0, < 5.1.6.1≥ 5.2.0, < 5.2.1.1
| 4.2.115.0.7.15.1.6.15.2.1.1
|
Description
A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have.
NVD description
A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free