In breve
- CVE-2018-16493 è una vulnerabilità ALTO (CVSS 7.5) che riguarda static-resource-server (static-resource-server project), static-resource-server.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.8%, superiore al 78.2% delle vulnerabilità.
- Nessuna versione corretta ancora nota: segui l'avviso del produttore nei riferimenti.
Description
Versions of simplehttpserver prior to 0.2.1 are vulnerable to Path Traversal. Due to insufficient input sanitization, attackers can access server files by using relative paths.
Recommendation
Upgrade to version 0.2.1 or later.
NVD description
A path traversal vulnerability was found in module static-resource-server 1.7.2 that allows unauthorized read access to any file on the server by appending slashes in the URL.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free