In breve
- CVE-2018-3711 è una vulnerabilità ALTO (CVSS 7.5) che riguarda fastify (fastify), fastify.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.8%, superiore al 78.1% delle vulnerabilità.
- Correzione: aggiornare a 0.38.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| fastify | < 0.38.0
| 0.38.0
|
| fastify npm | < 0.38.0
| 0.38.0
|
Description
Affected versions of fastify are vulnerable to a denial of service when processing a request with Content-Type set to application/json and a very large payload.
Recommendation
Update to version 0.38.0 or later.
NVD description
Fastify node module before 0.38.0 is vulnerable to a denial-of-service attack by sending a request with "Content-Type: application/json" and a very large payload.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free