In breve
- CVE-2018-3715 è una vulnerabilità MEDIO (CVSS 6.5) che riguarda glance (glance project), glance.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.5%, superiore al 73.6% delle vulnerabilità.
- Correzione: aggiornare a 3.0.4 o successiva.
| Package | Affected versions | Patched versions |
|---|
| glance | < 3.0.4
| 3.0.4
|
| glance npm | < 3.0.4
| 3.0.4
|
Description
Versions of glance before 3.0.4 are vulnerable to a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Recommendation
Update to version 3.0.4 or later.
NVD description
glance node module before 3.0.4 suffers from a Path Traversal vulnerability due to lack of validation of path passed to it, which allows a malicious user to read content of any file with known path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free