In breve
- CVE-2018-3734 è una vulnerabilità ALTO (CVSS 7.5) che riguarda stattic (stattic project), stattic.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.9%, superiore al 79.6% delle vulnerabilità.
- Correzione: aggiornare a 0.3.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| stattic | = 0.2.3
| No fix yet |
| stattic npm | < 0.3.0
| 0.3.0
|
Description
Versions of stattic before 0.3.0 are vulnerable to path traversal allowing a remote attacker to read arbitrary files with any extension from the server that users stattic.
Recommendation
Update to version 0.3.0 or later.
NVD description
stattic node module suffers from a Path Traversal vulnerability due to lack of validation of path, which allows a malicious user to read content of any file with known path.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free