In breve
- CVE-2018-3745 è una vulnerabilità CRITICO (CVSS 9.1) che riguarda atob (atob project), atob.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 2.1%, superiore al 82.0% delle vulnerabilità.
- Correzione: aggiornare a 2.1.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| atob | ≤ 2.0.3
| No fix yet |
| atob npm | < 2.1.0
| 2.1.0
|
Description
Versions of atob before 2.1.0 uninitialized Buffers when number is passed in input on Node.js 4.x and below.
Recommendation
Update to version 2.1.0 or later.
NVD description
atob 2.0.3 and earlier allocates uninitialized Buffers when number is passed in input on Node.js 4.x and below.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free