In breve
- CVE-2018-3752 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda merge-options (merge-options project), merge-options.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.4%, superiore al 73.1% delle vulnerabilità.
- Correzione: aggiornare a 1.0.1 o successiva.
Description
All versions of merge-options are vulnerable to Prototype Pollution
Recommendation
Update to version 1.0.1 or greater.
NVD description
The utilities function in all versions <= 1.0.0 of the merge-options node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free