In breve
- CVE-2019-0187 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda org.apache.jmeter:ApacheJMeter, jmeter (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 2.6%, superiore al 85.6% delle vulnerabilità.
- Correzione: aggiornare a 5.1 o successiva.
Description
Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.
NVD description
Unauthenticated RCE is possible when JMeter is used in distributed mode (-r or -R command line options). Attacker can establish a RMI connection to a jmeter-server using RemoteJMeterEngine and proceed with an attack using untrusted data deserialization. This only affect tests running in Distributed mode. Note that versions before 4.0 are not able to encrypt traffic between the nodes, nor authenticate the participating nodes so upgrade to JMeter 5.1 is also advised.
Altre vulnerabilità di org.apache.jmeter:ApacheJMeter
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free