| Package | Affected versions | Patched versions |
|---|---|---|
| python-apt | ≥ 0.9.0, < 0.9.3.5ubuntu3≥ 1.0.0, < 1.1.0≥ 1.2.0, < 1.6.5ubuntu0.1≥ 1.7.0, < 1.9.0ubuntu1.2< 0.8.3ubuntu7.5 | 0.9.3.5ubuntu31.1.01.6.5ubuntu0.11.9.0ubuntu1.20.8.3ubuntu7.5 |
| python-apt | = 1.8.4 | |
| python-apt | = 0.8.0= 0.8.1= 0.8.3= 0.8.9.1= 0.9.0= 0.9.1= 0.9.3.1= 0.9.3.2= 0.9.3.3= 0.9.3.4= 0.9.3.5= 1.0.1= 1.1.0= 1.4.0= 1.6.0= 1.6.1= 1.6.2= 1.6.3= 1.6.4= 1.7.0= 1.8.0= 1.8.1= 1.8.2= 1.8.3= 1.8.4= 1.9.0 |
python-apt only checks the MD5 sums of downloaded files in Version.fetch_binary() and Version.fetch_source() of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free