In breve
- CVE-2019-19588 è una vulnerabilità ALTO (CVSS 7.5) che riguarda validators, validators (validators project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.5%, superiore al 73.8% delle vulnerabilità.
- Correzione: aggiornare a 0.12.6 o successiva.
| Package | Affected versions | Patched versions |
|---|
| validators PyPI | ≥ 0.12.2, < 0.12.6
| 0.12.6
|
| validators | ≥ 0.12.2, ≤ 0.12.5
| No fix yet |
Description
The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.
NVD description
The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free