In breve
- CVE-2019-25158 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda tts-api (pedroetb), tts-api.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 2.1%, superiore al 81.9% delle vulnerabilità.
- Correzione: aggiornare a 2.2.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| tts-api | < 2.2.0
| 2.2.0
|
| tts-api npm | < 2.2.0
| 2.2.0
|
Description
A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. This vulnerability affects the function onSpeechDone of the file app.js. The manipulation leads to os command injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 29d9c25415911ea2f8b6de247cb5c4607d13d434. It is recommended to upgrade the affected component. VDB-248278 is the identifier assigned to this vulnerability.
NVD description
A vulnerability has been found in pedroetb tts-api up to 2.1.4 and classified as critical. This vulnerability affects the function onSpeechDone of the file app.js. The manipulation leads to os command injection. Upgrading to version 2.2.0 is able to address this issue. The patch is identified as 29d9c25415911ea2f8b6de247cb5c4607d13d434. It is recommended to upgrade the affected component. VDB-248278 is the identifier assigned to this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free