In breve
- CVE-2019-5413 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda morgan (morgan project), morgan.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 3.4%, superiore al 88.9% delle vulnerabilità.
- Correzione: aggiornare a 1.9.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| morgan | < 1.9.1
| 1.9.1
|
| morgan npm | < 1.9.1
| 1.9.1
|
Description
Verisons of morgan before 1.9.1 are vulnerable to code injection when user input is allowed into the filter or combined with a prototype pollution attack.
Recommendation
Update to version 1.9.1 or later.
NVD description
An attacker can use the format parameter to inject arbitrary commands in the npm package morgan < 1.9.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free