In breve
- CVE-2019-8323 è una vulnerabilità ALTO (CVSS 7.5) che riguarda rubygems-update, rubygems (rubygems).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 3.3%, superiore al 88.4% delle vulnerabilità.
- Correzione: aggiornare a 2.7.9, 3.0.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| rubygems-update RubyGems | ≥ 2.6.0, < 2.7.9≥ 3.0.0, < 3.0.2
| 2.7.93.0.2
|
| rubygems | ≥ 2.6.0, ≤ 3.0.2
| No fix yet |
Description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Gem::GemcutterUtilities#with_response may output the API response to stdout as it is. Therefore, if the API side modifies the response, escape sequence injection may occur.
NVD description
An issue was discovered in RubyGems 2.6 and later through 3.0.2. Gem::GemcutterUtilities#with_response may output the API response to stdout as it is. Therefore, if the API side modifies the response, escape sequence injection may occur.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free