In breve
- CVE-2020-15098 è una vulnerabilità ALTO (CVSS 8.8) che riguarda typo3/cms, typo3/cms-core, typo3 (typo3).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 2.2%, superiore al 82.7% delle vulnerabilità.
- Correzione: aggiornare a 10.4.6, 9.5.20 o successiva.
| Package | Affected versions | Patched versions |
|---|
| typo3/cms Packagist | ≥ 10.0.0, < 10.4.6≥ 9.0.0, < 9.5.20
| 10.4.69.5.20
|
| typo3/cms-core Packagist | ≥ 10.0.0, < 10.4.6≥ 9.0.0, < 9.5.20
| 10.4.69.5.20
|
| typo3 | ≥ 10.0.0, < 10.4.6≥ 9.0.0, < 9.5.20
| 10.4.69.5.20
|
Description
Meta
- CVSS:
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C (8.2)
- CWE-325, CWE-20, CWE-200, CWE-502
Problem
It has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. This allows to inject arbitrary data having a valid cryptographic message authentication code (HMAC-SHA1) and can lead to various attack chains as described below.
- TYPO3-CORE-SA-2020-007, CVE-2020-15099: Potential Privilege Escalation
- the database server used for a TYPO3 installation must be accessible for an attacker (either via internet or shared hosting network)
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C (7.5, high)
- TYPO3-CORE-SA-2016-013, CVE-2016-5091: Insecure Deserialization & Remote Code Execution
- an attacker must have access to at least one Extbase plugin or module action in a TYPO3 installation
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C (9.1, critical)
The overall severity of this vulnerability is high (8.2) based on mentioned attack chains and the requirement of having a valid backend user session (authenticated).
Solution
Update to TYPO3 versions 9.5.20 or 10.4.6 that fix the problem described.
Credits
Thanks to TYPO3 security team member Oliver Hader who reported and fixed the issue.
References
NVD description
In TYPO3 CMS greater than or equal to 9.0.0 and less than 9.5.20, and greater than or equal to 10.0.0 and less than 10.4.6, it has been discovered that an internal verification mechanism can be used to generate arbitrary checksums. This allows to inject arbitrary data having a valid cryptographic message authentication code (HMAC-SHA1) and can lead to various attack chains including potential privilege escalation, insecure deserialization & remote code execution. The overall severity of this vulnerability is high based on mentioned attack chains and the requirement of having a valid backend user session (authenticated). This has been patched in versions 9.5.20 and 10.4.6.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free