In breve
- CVE-2020-15159 è una vulnerabilità ALTO (CVSS 7.6) che riguarda baserproject/basercms, basercms (basercms).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 2.2%, superiore al 82.2% delle vulnerabilità.
- Correzione: aggiornare a 4.3.7 o successiva.
Description
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) and Remote Code Execution (RCE).
- Impact: XSS to RCE via Arbitrary file upload.
- Attack vector is: Administrator must be logged in.
- Components are: ThemeFilesController.php, UploaderFilesController.php.
- Tested baserCMS Version : 4.3.6 (Latest)
- Affected baserCMS Version : 4.2.0 ~ 4.3.6 (XSS), 3.0.10 ~ 4.3.6 (RCE)
- Patches : https://basercms.net/security/20200827
Found by Vulnerability Research team in Flatt Security Inc.
NVD description
baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) and Remote Code Execution (RCE). This may be executed by logging in as a system administrator and uploading an executable script file such as a PHP file.The affected components are ThemeFilesController.php and UploaderFilesController.php. This is fixed in version 4.3.7.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free