In breve
- CVE-2020-15186 è una vulnerabilità BASSO (CVSS 2.7) che riguarda helm.sh/helm, helm.sh/helm/v3, helm (helm).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.96%, superiore al 61.6% delle vulnerabilità.
- Correzione: aggiornare a 2.16.11, 3.3.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| helm.sh/helm Go | < 2.16.11
| 2.16.11
|
| helm.sh/helm/v3 Go | ≥ 3.0.0, < 3.3.2
| 3.3.2
|
| helm | ≥ 2.0.0, < 2.16.11≥ 3.0.0, < 3.3.2
| 2.16.113.3.2
|
Description
Impact
Security researchers at Trail of Bits discovered that plugin names are not sanitized properly. As a result, a malicious plugin author could use characters in a plugin name that would result in unexpected behavior, such as duplicating the name of another plugin or spoofing the output to helm --help.
Specific Go Packages Affected
helm.sh/helm/v3/pkg/plugin
Patches
This issue has been patched in Helm 3.3.2.
Workarounds
Do not install untrusted Helm plugins. Examine the name field in the plugin.yaml file for a plugin, looking for characters outside of the [a-zA-Z0-9._-] range.
NVD description
In Helm before versions 2.16.11 and 3.3.2 plugin names are not sanitized properly. As a result, a malicious plugin author could use characters in a plugin name that would result in unexpected behavior, such as duplicating the name of another plugin or spoofing the output to `helm --help`. This issue has been patched in Helm 3.3.2. A possible workaround is to not install untrusted Helm plugins. Examine the `name` field in the `plugin.yaml` file for a plugin, looking for characters outside of the [a-zA-Z0-9._-] range.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free