In breve
- CVE-2020-36624 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda text_helpers, texthelpers (texthelpers project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.62%, superiore al 50.1% delle vulnerabilità.
- Correzione: aggiornare a 1.2.0, 1.1.0 o successiva.
Description
A vulnerability was found in ahorner text-helpers 1.1.0/1.1.1. This vulnerability affects unknown code of the file lib/text_helpers/translation.rb. The manipulation of the argument link leads to use of web link to untrusted target with window.opener access. The attack can be initiated remotely. Upgrading to version 1.2.0 can address this issue. The name of the patch is 184b60ded0e43c985788582aca2d1e746f9405a3. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216520.
NVD description
A vulnerability was found in ahorner text-helpers up to 1.0.x. It has been declared as critical. This vulnerability affects unknown code of the file lib/text_helpers/translation.rb. The manipulation of the argument link leads to use of web link to untrusted target with window.opener access. The attack can be initiated remotely. Upgrading to version 1.1.0 is able to address this issue. The name of the patch is 184b60ded0e43c985788582aca2d1e746f9405a3. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216520.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free