In breve
- CVE-2021-21238 è una vulnerabilità MEDIO (CVSS 6.5) che riguarda pysaml2, pysaml2 (pysaml2 project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.1%, superiore al 65.7% delle vulnerabilità.
- Correzione: aggiornare a 6.5.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| pysaml2 PyPI | < 6.5.0
| 6.5.0
|
| pysaml2 | < 6.5.0
| 6.5.0
|
Description
Impact
All users of pysaml2 that use the default CryptoBackendXmlSec1 backend and need to verify signed SAML documents are impacted. pysaml2 <= 6.4.1 does not validate the SAML document against an XML schema. This allows invalid XML documents to trick the verification process, by presenting elements with a valid signature inside elements whose content has been malformed. The verification is offloaded to xmlsec1 and xmlsec1 will not validate every signature in the given document, but only the first it finds in the given scope.
Patches
Users should upgrade to pysaml2 v6.5.0.
Workarounds
No workaround provided at this point.
References
No references provided at this point.
Credits
- Victor Schönfelder Garcia (isits AG International School of IT Security)
- Juraj Somorovsky (Paderborn University)
- Vladislav Mladenov (Ruhr University Bochum)
For more information
If you have any questions or comments about this advisory:
NVD description
PySAML2 is a pure python implementation of SAML Version 2 Standard. PySAML2 before 6.5.0 has an improper verification of cryptographic signature vulnerability. All users of pysaml2 that need to validate signed SAML documents are impacted. The vulnerability is a variant of XML Signature wrapping because it did not validate the SAML document against an XML schema. This allowed invalid XML documents to be processed and such a document can trick pysaml2 with a wrapped signature. This is fixed in PySAML2 6.5.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free