In breve
- CVE-2021-21391 è una vulnerabilità MEDIO (CVSS 6.5) che riguarda ckeditor5-engine (ckeditor), ckeditor5-font (ckeditor), ckeditor5-image (ckeditor).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.7%, superiore al 76.8% delle vulnerabilità.
- Correzione: aggiornare a 27.0.0 o successiva.
Description
Impact
A regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0.
Patches
The problem has been recognized and patched. The fix will be available in version 27.0.0.
For more information
Email us at [email protected] if you have any questions or comments about this advisory.
Acknowledgements
The CKEditor 5 team would like to thank Yeting Li for recognizing and reporting these vulnerabilities.
NVD description
CKEditor 5 provides a WYSIWYG editing solution. This CVE affects the following npm packages: ckeditor5-engine, ckeditor5-font, ckeditor5-image, ckeditor5-list, ckeditor5-markdown-gfm, ckeditor5-media-embed, ckeditor5-paste-from-office, and ckeditor5-widget. Following an internal audit, a regular expression denial of service (ReDoS) vulnerability has been discovered in multiple CKEditor 5 packages. The vulnerability allowed to abuse particular regular expressions, which could cause a significant performance drop resulting in a browser tab freeze. It affects all users using the CKEditor 5 packages listed above at version <= 26.0.0. The problem has been recognized and patched. The fix will be available in version 27.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free