In breve
- CVE-2021-27291 è una vulnerabilità ALTO (CVSS 7.5) che riguarda pygments, pygments (pygments).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 3.9%, superiore al 90.3% delle vulnerabilità.
- Correzione: aggiornare a 2.7.4 o successiva.
| Package | Affected versions | Patched versions |
|---|
| pygments PyPI | ≥ 1.1, < 2.7.4
| 2.7.4
|
| pygments | ≥ 1.1, < 2.7.4
| 2.7.4
|
Description
In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.
NVD description
In pygments 1.1+, fixed in 2.7.4, the lexers used to parse programming languages rely heavily on regular expressions. Some of the regular expressions have exponential or cubic worst-case complexity and are vulnerable to ReDoS. By crafting malicious input, an attacker can cause a denial of service.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free