In breve
- CVE-2021-29469 è una vulnerabilità ALTO (CVSS 7.5) che riguarda redis (redis.js), redis.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.6%, superiore al 76.3% delle vulnerabilità.
- Correzione: aggiornare a 3.1.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| redis | < 3.1.1
| 3.1.1
|
| redis npm | ≥ 2.6.0, < 3.1.1
| 3.1.1
|
Description
Impact
When a client is in monitoring mode, the regex begin used to detected monitor messages could cause exponential backtracking on some strings. This issue could lead to a denial of service.
Patches
The problem was fixed in commit 2d11b6d and was released in version 3.1.1.
References
#1569 (GHSL-2021-026)
NVD description
Node-redis is a Node.js Redis client. Before version 3.1.1, when a client is in monitoring mode, the regex begin used to detected monitor messages could cause exponential backtracking on some strings. This issue could lead to a denial of service. The issue is patched in version 3.1.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free