| Package | Affected versions | Patched versions |
|---|---|---|
| puma | ≥ 5.0.0, < 5.3.1< 4.3.8 | 5.3.14.3.8 |
| puma | ≥ 5.0.0, < 5.3.1< 4.3.8 | 5.3.14.3.8 |
This vulnerability is related to CVE-2019-16770.
The fix for CVE-2019-16770 was incomplete. The original fix only protected existing connections that had already been accepted from having their requests starved by greedy persistent-connections saturating all threads in the same process. However, new connections may still be starved by greedy persistent-connections saturating all threads in all processes in the cluster.
A puma server which received more concurrent keep-alive connections than the server had threads in its threadpool would service only a subset of connections, denying service to the unserved connections.
This problem has been fixed in puma 4.3.8 and 5.3.1.
Setting queue_requests false also fixes the issue. This is not advised when using puma without a reverse proxy, such as nginx or apache, because you will open yourself to slow client attacks (e.g. slowloris).
The fix is very small. A git patch is available here for those using unsupported versions of Puma.
If you have any questions or comments about this advisory:
Thank you to @MSP-Greg, @wjordan and @evanphx for their review on this issue.
Thank you to @ioquatix for providing a modified fork of wrk which made debugging this issue much easier.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free