In breve
- CVE-2021-32650 è una vulnerabilità ALTO (CVSS 8.8) che riguarda october/system, october (octobercms).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 2.1%, superiore al 81.6% delle vulnerabilità.
- Correzione: aggiornare a 1.1.6, 1.0.473 o successiva.
| Package | Affected versions | Patched versions |
|---|
| october/system Packagist | ≥ 1.1.0, < 1.1.6< 1.0.473
| 1.1.61.0.473
|
| october | = 1.0.472= 1.1.5
| No fix yet |
Description
Impact
Assuming an attacker with access to the backend is able to execute PHP code by using the theme import feature. This will bypass the safe mode feature that prevents PHP execution in the CMS templates.
Patches
Issue has been patched in Build 473 and v1.1.6
Workarounds
Apply https://github.com/octobercms/october/commit/167b592eed291ae1563c8fcc5b9b34a03a300f26 to your installation manually if you are unable to upgrade.
References
Credits to:
• Sushi Yushi
For more information
If you have any questions or comments about this advisory:
NVD description
October CMS is a self-hosted content management system (CMS) platform based on the Laravel PHP Framework. Prior to versions 1.0.473 and 1.1.6, an attacker with access to the backend is able to execute PHP code by using the theme import feature. This will bypass the safe mode feature that prevents PHP execution in the CMS templates.The issue has been patched in Build 473 (v1.0.473) and v1.1.6. Those unable to upgrade may apply the patch to their installation manually as a workaround.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free