| Package | Affected versions | Patched versions |
|---|---|---|
| typo3/cms | ≥ 10.0.0, < 10.4.18≥ 11.0.0, < 11.3.1≥ 9.0.0, < 9.5.28 | 10.4.1811.3.19.5.28 |
| typo3/cms-core | ≥ 10.0.0, < 10.4.18≥ 11.0.0, < 11.3.1≥ 9.0.0, < 9.5.28 | 10.4.1811.3.19.5.28 |
| typo3 | ≥ 10.0.0, ≤ 10.4.17≥ 11.0.0, ≤ 11.3.0≥ 9.0.0, ≤ 9.5.287 |
Meta
- CVSS:
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N/E:F/RL:O/RC(5.0)
Failing to properly encode Page TSconfig settings, corresponding page preview module (Web>View) is vulnerable to persistent cross-site scripting. A valid backend user account is needed to exploit this vulnerability.
Update to TYPO3 versions 9.5.28, 10.4.18, 11.3.1 that fix the problem described.
Thanks to TYPO3 core merger Oliver Bartsch who reported and fixed the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free