In breve
- CVE-2021-32723 è una vulnerabilità MEDIO (CVSS 6.5) che riguarda application express (oracle), prism (prismjs), prismjs.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 1.4%, superiore al 72.9% delle vulnerabilità.
- Correzione: aggiornare a 21.1.4, 1.24.0 o successiva.
Description
Some languages before 1.24.0 are vulnerable to Regular Expression Denial of Service (ReDoS).
Impact
When Prism is used to highlight untrusted (user-given) text, an attacker can craft a string that will take a very very long time to highlight. Do not use the following languages to highlight untrusted text.
Other languages are not affected and can be used to highlight untrusted text.
Patches
This problem has been fixed in Prism v1.24.
References
- PrismJS/prism#2774
- PrismJS/prism#2688
NVD description
Prism is a syntax highlighting library. Some languages before 1.24.0 are vulnerable to Regular Expression Denial of Service (ReDoS). When Prism is used to highlight untrusted (user-given) text, an attacker can craft a string that will take a very very long time to highlight. This problem has been fixed in Prism v1.24. As a workaround, do not use ASCIIDoc or ERB to highlight untrusted text. Other languages are not affected and can be used to highlight untrusted text.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free