In breve
- CVE-2021-32805 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda flask-appbuilder, flask-appbuilder (dpgaspar).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.70%, superiore al 53.2% delle vulnerabilità.
- Correzione: aggiornare a 3.3.2 o successiva.
Description
Impact
If using Flask-AppBuilder OAuth, an attacker can share a carefully crafted URL with a trusted domain for an application built with Flask-AppBuilder, this URL can redirect a user to a malicious site. This is an open redirect vulnerability
Patches
Install Flask-AppBuilder 3.2.2 or above
Workarounds
Filter HTTP traffic containing ?next={next-site} where the next-site domain is different from the application you are protecting
NVD description
Flask-AppBuilder is an application development framework, built on top of Flask. In affected versions if using Flask-AppBuilder OAuth, an attacker can share a carefully crafted URL with a trusted domain for an application built with Flask-AppBuilder, this URL can redirect a user to a malicious site. This is an open redirect vulnerability. To resolve this issue upgrade to Flask-AppBuilder 3.2.2 or above. If upgrading is infeasible users may filter HTTP traffic containing `?next={next-site}` where the `next-site` domain is different from the application you are protecting as a workaround.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free