In breve
- CVE-2021-36162 è una vulnerabilità ALTO (CVSS 8.8) che riguarda org.apache.dubbo:dubbo, dubbo (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 2.3%, superiore al 83.0% delle vulnerabilità.
- Correzione: aggiornare a 3.0.2, 2.7.13 o successiva.
| Package | Affected versions | Patched versions |
|---|
| org.apache.dubbo:dubbo Maven | ≥ 3.0.0, < 3.0.2< 2.7.13
| 3.0.22.7.13
|
| dubbo | ≥ 2.7.0, ≤ 2.7.12≥ 3.0.0, ≤ 3.0.1
| No fix yet |
Description
Apache Dubbo supports various rules to support configuration override or traffic routing (called routing in Dubbo). These rules are loaded into the configuration center (eg: Zookeeper, Nacos, ...) and retrieved by the customers when making a request in order to find the right endpoint. When parsing these YAML rules, Dubbo customers will use SnakeYAML library to load the rules which by default will enable calling arbitrary constructors. An attacker with access to the configuration center he will be able to poison the rule so when retrieved by the consumers, it will get RCE on all of them. This was fixed in Dubbo 2.7.13, 3.0.2
NVD description
Apache Dubbo supports various rules to support configuration override or traffic routing (called routing in Dubbo). These rules are loaded into the configuration center (eg: Zookeeper, Nacos, ...) and retrieved by the customers when making a request in order to find the right endpoint. When parsing these YAML rules, Dubbo customers will use SnakeYAML library to load the rules which by default will enable calling arbitrary constructors. An attacker with access to the configuration center he will be able to poison the rule so when retrieved by the consumers, it will get RCE on all of them. This was fixed in Dubbo 2.7.13, 3.0.2
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free